Introduction and Objectives

Microsoft Access 2003 is a powerful, yet easy to learn, relational database application for Microsoft Windows. This tutorial is designed for users who are new or only have little experience using Access 2003. It introduces fundamental database concepts and operations and illustrates how they are performed in Microsoft Access 2003. This tutorial does not cover all of the features and functions of Microsoft Access 2003; emphasis will be on basic and frequently-used features, such as the creation of tables and queries, or importing spreadsheet into Access.

Please be aware that Microsoft Access is only available for Windows users; Mac users may want to seek out a FileMaker Pro Tutorial.

Objectives

By using this tutorial, you will learn to perform the following operations in Access 2003:

- Launch Access and identify the parts of the screen.
- Define fields and field properties constructing table structures.
- Enter and edit records in a table.
- Find, sort data.
- Design custom queries to display data.
- Import and export data between Excel and Access.

Definitions

These words are used often in Access so you will want to become familiar with them before using the program and this tutorial.

Relational Database: in relational databases such as Access, data is stored in tables made up of one or more fields (Access calls a column a field). The data stored in each
column must be of a single data type such as Character, Number or Date. A collection of values from each column of a table is called a record or a row in the table. Different tables can have the same column in common. This feature is used to explicitly specify a relationship between two tables. Values appearing in column A in one table are shared with another table.

**Table:** tables are the main units of data storage in a database. A table is a collection of data about a specific topic; it is made up of one or more fields.

**Field:** a field is a column in a table and defines a data type for a set of values in a table. For example, a mailing list table might include fields for first name, last name, address, city, state, zip code, and telephone number.

**Record:** a record is a row in a table and is a set of values defined by fields. In a mailing list table, each record would contain the data for one person as specified by the intersecting fields.

**Data type:** data types are the properties of each field. A field only has one data type, such as Character, Number or Date.

**Primary Key:** a primary key is a value that can be used to identify a unique record in a table.

**Design View:** it provides the tools for creating fields in a table.

**Datasheet View:** it allows you to update, edit, and delete information from a table.

**Access vs. Excel**

Access databases and Excel spreadsheets although originally very different, have evolved to have similar functions. Although either type of program can do many, but not all, of the things that the other one does, there are some things which are easier in one program than the other.

Excel is not database management systems. Excel spreadsheets store data in rows and columns called worksheets. The areas within the worksheet where the rows and columns intersect are called cells. The most common use of spreadsheets is to manage basic information such as telephone numbers, employee names, financial data, calculations, etc.
Access stores data in tables that look similar to worksheets but function quite differently. Tables, the foundation of all relational databases function both independently and interdependently with other tables to allow the database user to combine data from multiple sources and analyze and/or report information in almost limitless ways.

**The Access Interface**

This section introduces the Access interface and discusses how to use menus and toolbars, create databases and switch between database components.

**Starting Access and Opening a Database**

1. Click on the **START** button on your computer and position your cursor over the **PROGRAMS** menu to view a list of installed programs. Once you see the list, position the cursor over **Microsoft Office** and then click on **Microsoft Access**.

2. After opening Access, you will be presented with the window shown in Figure 1.

3. If you want to edit an existing database, you can either go to **File—Open**, or move your cursor to the lower right-hand side to click on **Open**.
4. If you are creating a new database, you can also either go to **File—New**, or move your cursor to the lower right-hand side to click on **Create a new file**. You will be presented with five options on the right side menu as shown in Figure 2.

![Figure 2](image)

5. Unlike Word documents, Excel spreadsheets, and Power Point presentations, you must save an Access database before you start working on it. After selecting "Blank database", you will first be prompted to specify a location and name for the database. In the New Database dialog box, type in a name for the database and a location and click on **Create** as shown in Figure 3.

![Figure 3](image)

6. Now a new database is created as shown in Figure 4.
Database Components

An Access database consists of several different components. Each component listed is called an *object*.

Listed below are the names and descriptions of the different objects you can use in Access. This tutorial will focus on the first two objects: tables and queries.

**Tables**
Tables are where the actual data is defined and entered. Tables consist of records (rows) and fields (columns).

**Queries**
Queries are basically questions about the data in a database. A query consists of specifications indicating which fields, records, and summaries you want to see from a database. Queries allow you to extract data based on the criteria you define.

**Forms**
Forms are designed to ease the data entry process. For example, you can create a data entry form that looks exactly like a paper form. People generally prefer to enter data into a well-designed form, rather than a table.
Reports
When you want to print records from your database, design a report. Access even has a wizard to help produce mailing labels.

Pages
A data access page is a special type of Web page designed for viewing and working with data from the Internet or an intranet. This data is stored in a Microsoft Access database or a Microsoft SQL Server database.

Macros
A macro is a set of one or more actions that each performs a particular operation, such as opening a form or printing a report. Macros can help you automate common tasks. For example, you can run a macro that prints a report when a user clicks a command button.

Modules
A module is a collection of Visual Basic for Applications declarations and procedures that are stored together as a unit.

Building Database Tables
This section describes how to construct data tables, enter and edit data, sort records, and find records that meet certain conditions.

Creating Tables in Design View

1. By clicking the Table tab on the left hand side, you will find Access provides three ways to create a table for which there are icons in the Database window.

   - Create Table in Design view will allow you to create the fields of the table. It allows you to define the fields in the table before adding any data to the datasheet. This is the most common way of creating a table and is explained in detail below.
   - Create table by using wizard will step you through the creation of a table.
   - Create table by entering data will give you a blank datasheet with unlabelled columns that looks much like an Excel worksheet.
2. Double clicking on Create table in Design view displays the Table Design screen where you define fields for your table. The screen is divided into two parts: a top pane for entering the field name, data type, and an option description of the field and a bottom pane for specifying field properties.

![Figure 5](image5.png)

3. Every table consists of fields. For each field, specify the name of the field, the type of data, and any description needed to determine what data the field contains. Pressing the Tab key moves the cursor from one column to the next in the Table Design screen. You can select the data type from the drop-down list in the Data Type column as shown in Figure 6.

![Figure 6](image6.png)
4. Each table in your database should have a “primary key.” A primary key is a field that uniquely identifies each record in the database. In a database of book collection, there might be two books with the same author so author is not a good primary key. However, every book has a unique “call number”, so “call number” would be a good choice for a primary key. To set the primary key for your table, highlight the key field and choose **Primary Key** from the Edit menu.

![Figure 7](image)

5. When the primary key is set, you should find a little key icon next to the field name on the left side. Note: To remove a primary key, simply repeat this procedure to toggle the primary key off.

![Figure 8](image)

6. As a final step, the table must be saved. Pull down the File Menu to choose **Save**. A dialogue box will pop up where the name of the new table should be specified. Access gives a default name such as “Table1” or “Table2.” Simply type over this default name with the name of the table. For this example, name the table “Book_Info”, then click **OK**.

![Figure 9](image)
7. At this point, the new table has been created and saved. Switch back to the Access main screen by pulling down the File menu and choosing **Close**. This will **close** the Design View for the table and display the Access main screen. Notice that the new Book_Info table appears below the Table tab.

![Figure 10](image)

**Adding and Deleting Fields to Tables**

Even the best planned database will sometimes require you to add or delete a field in the Design View. To add a new field, select the row you want to insert above and choose “Row” from the Insert menu. If you need to delete a field, select the row containing the field and choose “Delete Row” from the Edit menu.

You can also move fields in the table design. Select the field you want to move by clicking on its row. A black triangle will appear to indicate the field is selected. Then, drag the field to the new location.

**Cautions to Modifying your Table Design Structure**

- Backup your table before you make any modifications to it.
- Deleting a field will delete the records in the field.
• If you delete a field and that field is used in any of your forms, queries or reports, you must also delete that field from these other documents.
• Renaming a field will have the same effect on a table as deleting the field.
• Resizing a field (making it smaller) may truncate the data in your forms or reports.

**Entering and Editing Data**

1. After you have defined fields in the table, you can enter data. Highlight the table, choose **Open** from the database window menu bar. This displays a grid with field names across the top and a row for each record of the database as shown in Figure 11.

2. To enter data, simply click the mouse in the field you want to enter and type a value. Press the **Tab** key to move from field to field. When you are in the last field of a record, pressing the Tab key automatically creates a new record for you.

3. The table in Figure 12 is shown in Datasheet View. Use the **Datasheet View** to add, delete, and move records.
4. To save the new data, pull down the **File** menu and choose **Save**.

5. To navigate to other records in the table, use the navigation bar at the bottom of the screen:

**Sorting and Finding Records**

Two of the most common database tasks are sorting records and searching for records that meet a particular condition. Fortunately, both of these operations are easy to perform while viewing the table datasheet.

**Sorting Records**

To sort records by a particular field, select the field you want to sort. From the **Records** menu select **Quick Sort** then choose either **Ascending** or **Descending** order. Access quickly sorts the records by the selected field.

**Finding Records**

If you want to locate a record that contains a certain name or date use the **Find** command on the **Edit** menu. Type the search string in the **Find What** box and click **Find First**. Access will highlight the first record that contains the search string.
Table Relationships

To prevent the duplication of information in a database by repeating fields in more than one table, table relationships can be established to link fields of tables together. Follow the steps below to set up a relational database:

1. Click the Relationships button on the toolbar:

2. From the Show Table window (click the Show Table button on the toolbar to make it appear), double click on the names of the tables you would like to include in the relationships. When you have finished adding tables, click Close.

3. To link fields in two different tables, click and drag a field from one table to the corresponding field on the other table and release the mouse button. The Edit Relationships window will appear as shown in Figure 14. From this window, select different fields if necessary and select an option from Enforce Referential Integrity if necessary. These options give Access permission to automatically make changes to referential tables if key records in one of the tables are deleted. Check the Enforce Referential Integrity box to ensure that the relationships are valid and that the data is not accidentally deleted when data is added, edited, or deleted. Click Create to create the link.
4. A line now connects the two fields in the Relationships window as shown in Figure 15. Note the symbols "1" (indicating the "One" side) and the infinity symbol (indicating the "Many" side) on the relationship. Close the relationships screen and select Yes to save the changes to the Relationships layout.
Creating Queries

A query is simply a question you ask a database. How many books are written by a certain author? Who wrote a book in a certain year? Queries select records from one or more tables in a database that match the criteria you set, they can be viewed, analyzed, and sorted on a common datasheet. The resulting collection of records, called a dynaset (short for dynamic subset), is saved as a database object and can therefore be easily used in the future. The query will be updated whenever the original tables are updated.

1. To construct a query, Click on the New button in the database window as shown in Figure 16. Choose Design View, click OK.

2. In the Show Table dialog box as shown in Figure 17, you will be asked to choose a table/tables for the query. Select the tables you want to query and click Add.
3. Add fields from the tables to the new query by double-clicking the field name in the table boxes or selecting the field from the Field and Table drop-down menus on the query form as shown in Figure 18. Specify sort orders if necessary.

![Figure 18](image)

4. Enter the criteria for the query in the Criteria field. The Expression Builder can also be used to assist in writing the expressions in the Criteria field.

5. After you have selected all of the fields and tables, click the Run button on the toolbar to execute the query. Figure 19 shows the query result, records that match the criteria you set.

![Figure 19](image)

6. Choose Save from the File menu to save a query for later execution.

**Importing Excel data to Access**

1. To format data in an Excel spreadsheet, you need to make sure the data is list format. This means that each column has a label in the first row and contains similar facts, and
there are no blank rows or columns within the list. Then, close the Excel workbook that contains the data you want to use in Access.

2. In Access, open the database (if you already have one) or create a new database where you want to copy the Excel data.

3. On the Access File menu, point to Get External Data, and then click Import.

4. In the Import dialog box, click Microsoft Excel in the Files of type box. Then locate the file you want to import, and then double-click the file.

5. After you select the spreadsheet to import, you'll be presented with a new screen asking you to select the Worksheet or Named Range that you wish to import. In the example here, there is only one worksheet. Select the worksheet and click Next.
6. Specify whether column headings are present. Often, Excel users utilize the first row of their spreadsheet to provide column names for their data. In our example file, we did this to identify Author_ID, etc. In the window shown below, ensure that the **First Row Contains Column Headings** box is checked. This will tell Access to treat the first row as names, rather than actual data to be stored in the list. Click the **Next** button to continue.
7. Choose a destination type. If you're working with a brand-new database, you'll want to check the **In a New Table** radio box. If you are importing data into an existing database, you could specify the destination table here. Click the **Next** button to continue.

![Figure 24: Import Spreadsheet Wizard](image)

8. Create any desired indices. Database indices are an internal mechanism that can be used to increase the speed at which Access can find information in your database. You can apply an index to one or more of your database columns at this step. Simply click the **Indexed** pull-down menu and select the appropriate option.
9. Select a primary key. You can either let Access generate a primary key for you, or you can define one of the fields in your worksheet as primary key.

10. The last step is to name your table and click **Finish**. A dialogue box will appear to inform you that your spreadsheet has been imported successfully.
11. Return to the database window, you will find the new table a part of your database now.

**Quitting Access**

To quit Access, choose **Exit** from the **File** menu.
Resources:

http://www.katsueydesignworks.com/tutorials_databases.htm

http://www.fgcu.edu/support/office2000/access/

http://cisnet.baruch.cuny.edu/holowczak/classes/2200/access/accessall.html