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Objectives  
 
Website construction and maintenance is quickly becoming a necessary skill in both academic and 
working spheres. Whether you're new to web design or just new to Dreamweaver, this tutorial will 
help explain the ins and outs of this popular program. By the end, you’ll be able to create web pages 
with ease. This tutorial has the following objectives: 
 

• Explore interface, menus & properties manager  
• Create a basic web page  
• Add text, links, tables and images  
• Change fonts and alignment  
• Review transferring files and images to the server and learn techniques for effective 

management of your server space.  

Dreamweaver is a web development tool that is available on all of the computers in the IT Lab. It 
can also be purchased for about $100 from the Campus Computer Store. For creating a simple web 
page, it may have more functionality than you really need. For large sites, however, the many 
features of Dreamweaver are invaluable.   

Need to create a simple web page, anxious about learning HTML, or unwilling to fork out the 
money to buy Dreamweaver? Mozilla Composer may just be a great alternative to Dreamweaver. 
Mozilla is an open source suite of applications used for web browsing, email, or creating html pages, 
which can be downloaded for free from the Internet (http://www.mozilla.org/). Mozilla Composer 
is the web development tool of Mozilla. All of the computers in the IT Lab have Mozilla Composer 
on them, and it is very easy to download it on your home computer. For more information about 
how to use Mozilla Composer, check out the Creating a Web Page Using Mozilla Composer tutorial 
(http://www.ischool.utexas.edu/technology/tutorials/webdev/mozilla/index.html).   
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Definitions 
 
Dreamweaver:   

 
 
 
 
Email link:    

 
 
 
Hyperlink: 

 
Insert  
Window: 
 
Properties  
Window: 
 
 
URL:    

An HTML editing and web page construction tool, offering a graphical 
user interface (GUI) for HTML functionality. In the School of 
Information’s IT lab, you’ll be given the choice of Dreamweaver 4 view 
or Dreamweaver MX view. 4 separates the windows, while MX provides 
a connected workspace. The preferred view is debatable, and in this 
case, entirely up to you. 
 
Creates a link which users can click on to send an email to the 
recipient. Simply click on the email link icon, and enter the appropriate 
info. Note: when using the Properties Window’s link field to create an 
email link, enter mailto:yourlogin@ischool.utexas.edu, no spaces.  
 
Creates a link that takes users to a specified URL. Note: when using the 
Properties Window’s link field, be sure to enter the entire URL (including 
http://). 
 
Offers a GUI for the insertion of images, links, tables, etc. It mirrors the 
functionality of the Insert menu on the main toolbar. 
 
Displays the current properties for links, text, tables, and objects.  
Allows for manual entering of dimensions and colors (including 
background, table cells, and text).  
 
A Uniform Resource Locator is commonly referred to as a “web 
address.” It includes such information as the protocol used to access 
the resource (e.g. http), the domain name of a computer or server 
connected to the Internet (e.g. www.ischool.utexas.edu), and the path 
of the sought resource (e.g. ~yourlogin/filename.extension). 

 
 
 
 
 
Getting Started 
 
Creating your site: 
Setting up a site in Dreamweaver allows you to easily manage, update, and locate your files.  Follow 
the next few steps closely to insure that your site setup will work for you: 
 

• Create a folder on the desktop (or any other place on your computer you will remember) – 
you will save your pages here until they are ready to post on-line. 

• From the main toolbar choose:  Site > Manage sites 
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A new window will open – we will be creating a new site: 
 

 
 
Next, give your site a name – this is just a name to help you recognize your files: 
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For most web work, server technology is not needed.  ColdFusion, ASP, and other server 
technology programs are typically used for database creation and support.  Suffice it to say – if you 
are just getting started with Dreamweaver, you should opt to NOT use server technologies at this 
point: 
 

 
 

You are next asked how you want to work with your files during the web development process.   It 
is suggested that you select to edit local copies on your machine before loading them on the web.  
This means that your files will be saved to your computer and then uploaded to your iSchool space 
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only when you perform the upload.  This often prevents costly mistakes, such as accidentally 
deleting a page or replacing a finished page with a work in progress.   
 

 
  
 
 
Next, you will tell Dreamweaver how to connect to your iSchool server space: 
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There are many ways to connect to your server space; we will always use FTP (File Transfer 
Protocol) at the School of Information. If you use SSH, WFTP, or Fetch, you are familiar with 
the following fields. The FTP address is login.ischool.utexas.edu or ftp.ischool.utexas.edu. This 
allows Dreamweaver to transfer files between your computer (or local machine) and the server 
(or remote machine). You will choose your public_html folder to store your files.  Everything 
you place in this folder is viewable on-line, if the correct path, filename, and extension are used. 
Your FTP login and password are the same login and password you use for your School of 
Information account.  
 
Test the connection before you continue…typos are frequent and easier to deal with in the 
moment, than later when you are trying to understand why you can’t connect. 

 
Dreamweaver also has capabilities to facilitate a site on which multiple people are editing and 
authoring files.  “Check in” and “check out” should not be used if you are the only person 
working on your website.  However, if you’re working with a group, it can be very helpful.  For 
example:  If you’re working on a group project for your Information Architecture course and 
many people have access to the account for the web site you are building for your final project, 
there is no way to know if someone is working on the same file as you or when s/he will upload 
it.  You risk losing your work and/or your team member’s work.  “Check in” and “Check out” 
will allow only one team member at a time access to a file.   
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The final page of the wizard displays a summary of your website setup preferences -- check that 
these are correct and click DONE! 
 

 
 
 
After you set up your site, the following window will appear: 
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Getting Comfortable 
 
Creating your page 
 
Now you’re ready to begin! There are two ways to get started with Dreamweaver: Either select a 
new HTML file or open a new document by going to File  New. 
 
Dreamweaver MX operates much like Microsoft Word; just begin typing, inserting images, tables, 
etc. 
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Let’s take a look at the Dreamweaver interface:  several key toolbars – the properties window, the 
insert toolbar, and the file management window – offer quick access to many of Dreamweaver’s 
functionalities: 
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Page Views 
 
Dreamweaver offers three viewing options for working on and creating your page: 

1. Code – This view presents the user with only the HTML code. 
2. Design – This view presents the user with a GUI interface, similar to a word 

processing program, allowing for the creation of professional quality pages with 
little or no knowledge of code.   

3. Code and Design – The view splits the screen, providing the user with both the 
code (on top) and GUI (on the bottom). Highlighting text in the bottom, GUI 
portion, will highlight the code on top.  This offers the user a unique opportunity 
to learn code in a “subtitle” fashion. 

 
Preview your work in a browser 
 
While working on your web page, you may want to see how it will look when it’s posted or in a 
browser. There are two ways to achieve this goal. 

1. From the main toolbar select File > Preview in Browser. You may then select the 
default (Internet Explorer) or choose a new one (e.g., Mozilla, Netscape, Opera, 
Safari). 

2. When you feel more comfortable with Dreamweaver, you can use the hotkey, 
F12, to preview your work. 

 
Saving and Publishing your page 
 

• When you are ready to publish your work, the first 
step is saving it to your local folder.  Next, click on 
the “Expand / Collapse” Button at the right of the 
Local View window to see a split view of your local 
files and your remote files – this will show you both 
what you have saved locally, on your computer, and 
what’s on your iSchool server space inside your 
public_html folder. 

 
 

• Connect to your iSchool space by clicking on the 
“Connect to remote server” as illustrated below: 
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Finally, highlight the file or files you wish to upload and click on the “put” or upwards arrow at the 
top.  If your files transfer successfully to your iSchool server space, they will appear in the remote 
site area on the left side of the window: 
 

 
 
 
You can now view your page on-line by typing 
http://www.ischool.utexas.edu/~yourlogin/filename.html 
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Inserting an Image 
 
In Dreamweaver, there are many ways to accomplish any given task.  For instance, there are two 
ways to insert an image.  You could click on the image button in the insert content bar at the top: 
 

 
 
Or, you could click on “Insert” at the top and scroll down to “Image:” 
 

 
 
 
 
It is important to remember that Dreamweaver is an html editor, not an image editor. Make all 
adjustments to your image in Fireworks, Photoshop, the Gimp, etc., before inserting it into your 
Dreamweaver document.  This includes resizing the image, as you risk losing quality and correct  
proportions. 
 
There are certain features of your image that you can edit from the Properties window.  You can 
align an image, create a border around the image, add alternative text, allot horizontal and vertical 
space to pad your image, create an image map, and more: 
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Inserting a Table 
 
In HTML, tables offer a number of layout options. If you choose a border, the user will see the 
tabular structure. If you choose no border, the user only sees aligned text or images.  
  
You can insert a table in two ways: 
 1. The table icon on the Insert Window 
 2. File > Insert > Table 
  
Both options will yield a window with options for # of rows, # of columns, cell spacing, cell 
padding, width, and border: 
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Choose the dimensions and qualifications for your table and press OK. You have a table! 
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Links 
 
There are two types of links in this world: absolute and relative.  You should already be familiar with 
absolute links – these are links that are full URL addresses. Here’s one example:  
 http://www.ischool.utexas.edu 
Absolute links are used to direct a reader of your webpage outside your webpage.   
 
Relative links point to a specific file within your webpage – the file’s relation to the current directory 
or root directory.  For example, if you have two files in your public_html directory, homepage.html 
and school.html, to link from one to the other you only need to insert the filename into 
Dreamweaver’s link feature. When you have files within folders within your public_html folder, 
things become a little more complicated.  Let’s say you want to insert links on your homepage.html 
page to an image that is located in a folder named “images.” You need to tell browsers to look in the 
“images” directory to find your images. Therefore, any links from homepage.html to files in your 
image folder would be like this example: “images/gnomes.jpg.”  The name of the folder is reflected 
within the file name. 
 
As is the case with many of Dreamweaver's functions, there are many paths to the same end. My 
preferred method for inserting links is through the Properties window: 
 

 
 
•  Highlight the text you would like to link. 
 
•  Click in the "link" field in the Properties window. Enter the URL of the page you would like to 

link to. 
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•   If you are linking to a page within your site, you need only enter the filename. 
 
Anchors 
 
When writing papers or posting “information rich” pages, you may want to link within the page to 
afford the user more freedom of movement and choice (e.g. “back to top”). These situations call for 
named Anchors. 
When you insert a named anchor (from the Insert Window or main toolbar, Insert > Named 
Anchor) a tag is inserted into your document. To continue with the above example, insert one at the 
top of your document and call it “top:” 
 

 
 
Lower on your page (at least one screen length) type “back to top” or simply “top.”  
 
Highlight the word or phrase, then place your cursor in the link field of the Properties Window and 
type “#top”. The # is telling the browser to look for the anchor named “top:” 
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Page Properties 
 
An important new feature of Dreamweaver MX 2004 is the expanded Page Properties Menu.  From 
this menu, you can modify the text font, size, and color, as well as the background color of the 
entire page: 
 

 
 
Additionally, you can modify how links appear on your webpage by clicking on “Links” in the left 
window: 
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Conclusion 
 
When learning any new technological tool or software, it’s best to tinker to find what works and 
what works best for you. 
 
Additional Resources 
 
These are a few recommended resources for more information on best practices for web design, 
information architecture, and Dreamweaver: 

• www.w3.org - The World Wide Web Consortium offers standards for many web tools. 
• www.dynamicdrive.com - offers free DHTML and java scripts.  It sounds ominous, but they 

give great visual examples to choose from.  
• www.boxesandarrows.com - a bunch of information architects came together and you have 

boxes and arrows.  
• www.macromedia.com - info on current and upcoming Macromedia products. 
• www.sourceforge.net - claims to be “the largest repository of Open Source code and 

applications available on the Internet.”  
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